熱點推薦:
您现在的位置: 電腦知識網 >> 編程 >> PHP編程 >> 正文

解決PHP4.0 和 PHP5.0類構造函數的兼容問題

2013-11-15 12:37:13  來源: PHP編程 
以下是對解決PHP和PHP類構造函數兼容問題的方法進行了詳細的分析介紹需要的朋友可以過來參考一下  

  在 PHP 以上版本裡還兼容了 版本的構造函數的定義規則如果同時定義了的構造函數和 __construct()函數則__construct() 函數優先
為了使類代碼同時兼容 PHP可以采取以下的方式

復制代碼 代碼如下:

  
<?php
class MyClass {
 function __construct() { //for PHP
  echo this is class construct;
 }
 // 為了使類代碼同時兼容 PHP
 function MyClass() { //for PHP
  $this>__construct();
 }
}
$c = new MyClass;
?>


From:http://tw.wingwit.com/Article/program/PHP/201311/21295.html
    推薦文章
    Copyright © 2005-2013 電腦知識網 Computer Knowledge   All rights reserved.