熱點推薦:
您现在的位置: 電腦知識網 >> 編程 >> Java編程 >> Java開源技術 >> 正文

在Eclipse中安裝TomcatPlugin

2013-11-23 20:19:06  來源: Java開源技術 

  安裝 tomcatPlugin (安裝後可在 eclipse 中直接使用 tomcat )插件

  ① 下載地址

  可以下載最新的 tomcatPluginVbeta 版本它支持 eclipse 和 tomcat

  ② 在 D\eclipse 下新建文件夾命名為 myplugins (名稱可隨意)myplugins 下依次新建文件夾 tomcat eclipse plugins features 目錄結構如下

  D\eclipse\myplugins\tomcat\eclipse\features

  D\eclipse\myplugins\tomcat\eclipse\plugins

  把解壓後的 tomcatPlugin 文件夾放在此 plugins 目錄下

  ③ 在 D\eclipse\links 下新建一文本文件 tomcatlinktxt (文件名可隨意擴展名一定是 txt 或者 link ) 內容為 path=myplugins/tomcat

  (推薦使用也可使用絕對路徑 path=D\\eclipse\\myplugins\\tomcat )

  ④ 啟動 eclipse 可在菜單欄看到 Tomcat 選項此時還需對其進行配置Window ==>Preferences==>Tomcat選擇 Tomcat 版本 Versionx (我使用的是 Tomcat 放在 D\Tomcat 下對於 Tomcat 可選擇 Versionx )並設置 Tomcat home Context declaration mode 下有兩種選擇一種是 configuration file 默認放在 D\Tomcat\conf\serverxm 中一種是 Context directory 默認放在 D\Tomcat\conf\Catalina\localhost 下可根據需要自由選擇 ( 對於 Tomcat Context directory 默認放在 D\Tomcat\webapps 下 ) 在這裡我選擇 Context directory 並更改為 D\Tomcat\webapps (這裡選擇哪一種無所謂因為只是討論 tomcatPlugin 的使用 ~~ )

  ⑤ 在 Tomcat 菜單下啟動 tomcat 即可

  注意對於 eclipse+tomcatPluginbeta 在 Tomcat 和 Tomcat都可以在 eclipse 中正常啟動 tomcat 對於 Tomcat 在 eclipse 中啟動時 Console 會報錯

  Tomcatx[Java Application]C\Java\jdk\javawexe

  很奇怪報的是 Tomcatx 的錯可能是因為 beta 版的緣故吧所以大家最好在 apache 網站上下載 Tomcat 以上的版本(順便說一句 Tomcat 支持最新的 JSP 和 Servlet 在後面做了點比較以供參考) ~~

  ⑥ 上面 步是一種比較麻煩的安裝最簡單的辦法如下但這個方面不一定成功可能版本的原因吧!是 把解壓後的 tomcatPlugin 文件夾直接放到 D\eclipse\plugins 目錄下 啟動 eclipse 即可不過這樣安裝會導致 plugins 目錄 越來越大以後維護起來也不方便所以最好采用上面的 link 方式安裝 ~


From:http://tw.wingwit.com/Article/program/Java/ky/201311/28286.html
    推薦文章
    Copyright © 2005-2013 電腦知識網 Computer Knowledge   All rights reserved.